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A quick introduction to Discovery Studio (DS) user interface 

 

1. Tool panels (Macromolecule, Simulation, Receptor-Ligand Interactions, etc.) 

2. Toolbars 

3. Tool panel collections 

4. Hierarchy tree view 

5. Molecule window 

6. Molecular detail and navigation panel 

7. Protocol parameter window 

8. Jobs explorer 

9. Results window 

10. Server status 
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DS protocols for structure-based design (SBD) 

Discovery Studio is equipped with six different protocols for structure-based drug design: 

1. CDOCKER (a grid-based molecular docking method that employs CHARMm forcefield) 

2. GOLD (genetic algorithm for docking flexible ligands into a protein binding site) 

3. LibDock (algorithm for docking small molecules into an active receptor site) 

4. LigandFit (shape-based docking with Monte Carlo conformational sampling) 

5. CDOCKER with structure-based pharmacophore restraints 

6. Flexible Docking (CDOCKER-based method allowing protein side-chains flexibility) 

 

These protocols can be accessed under Protocols tab > Discovery Studio > Receptor-Ligand 
Interactions > Docking subdirectory. 

 

 

 

Note: The Protocols tab (DS collections) might be unavailable in case the DS Client is not 
connected to the AEP server (see AEP server status in the right-down corner of the DS-GUI) due 
to several reasons:  

- The client-server connection is down because of technical issues. 
- Another user is connected to the AEP server (licensing issues). 

In case you are connected to the AEP server and the Protocols tab are not visible, you can 
enable it manually (View > Explorers > Protocols). 
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Data accessibility and preparations for structure-based calculations 

In order to perform structure-based (molecular docking) calculations in DS, the accessibility to 
structural data (e.g., a protein, a ligand, or ideally a protein-ligand complex) of the biological 
system under consideration is necessary (e.g., protein database repository – www.rcsb.org). 
This can be done by downloading the X-ray, NMR or CryoEM structure manually from the 
www.rcsb.org repository or in an automated fashion directly through the DS interface.  

To automatically fetch the protein structure from the PDB repository in the DS environment, 
follow these two steps (see picture below):  

 

1. Click on the Open URL button on the toolbar. 

2. Write-down the PDB ID of the needed structure and click on the Open button. 

In this way, the downloaded structure will be automatically displayed in the Molecule window 
as solid-ribbon (see picture below). 
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In the next step, the downloaded protein structure should be prepared for structure-based 
calculations. To do this, click on the Macromolecule tool panel and open the Prepare Protein 
tools collection. Under the Automatic Preparation section click on Prepare Protein button. This 
will open the Prepare Protein parameter dialog (see picture below). 

 

The default Prepare Protein settings usually give good results (e.g., missing loops will be added 
and minimized, crystal waters will be removed, the entire protein structure will be protonated, 
etc.).  

As demonstrated on the picture above, Keep Water parameter is set to None by default that is 
good for most of the molecular docking calculations. Optionally, this parameter can be changed 
only in cases where some water molecules (usually surrounding the ligand in the binding 
pocket) are necessary for establishing ligand-protein interaction.  

When all parameters are defined, just click on the Run button and check when Prepare Protein 
job is done (check the job status in Jobs explorer).  

When Prepare Protein job is finished, double click the item in the Jobs explorer. This will open 
the Results window containing the job results. To visualize the prepared protein, click on the 
Prepare Protein Structure link or View Results button. The prepared protein structure will be 
opened in a new Molecule window (see next picture). 
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At this step, it is a good advice to save the prepared protein structure for future work (File > 
Save As… ) as *.dsv or *.pdb format. 

Once the protein structure is prepared (in this case a protein-ligand complex), the next step is 
to prepare it for structure-based (molecular docking) calculations. To easily access all the 
protein/ligand components, first close the Results window, click on the Molecule window 
where the protein structure is displayed and open the Hierarchy tree view by pressing Ctrl + H 
on the keyboard.  
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It should be noted however that during the Protein preparation step any other co-factors (e.g., 
metal ions) are not automatically removed from the structure and we should do it manually. 
This is somehow similar to the elimination of the water molecules described previously. Put 
differently, in the absence of a solid background to keep such co-factors and to use them in our 
calculations, we should remove them from the structure (see previous picture). In Hierarchy 
tree view, identify the unwanted co-factors, select them and press Delete (e.g., Cl- ion in the 
above example). Moreover, in the Hierarchy tree view, click on <Cell> and go to main menu 
(Structure > Crystal Cell > Remove Cell). This will remove the crystal cell covering the entire 
crystal structure. 

Now we should properly label the structure to be used for structure-based calculations. In the 
Hierarchy tree view, select the main structure tree (in our example it is named as 5CSW). Click 
on the Receptor-Ligand Interactions tool panel, go to Tools tab, open Define and Edit Binding 
Site tool collection and click on Define Receptor button. The structure label will appear in the 
Hierarchy tree view (see 5 on picture below). 

 

While we are still in the Hierarchy tree view, we should also identify the ligand molecule in 
order to define the binding site sphere where docking calculations will be performed. The 
binding site sphere can be defined by selecting a ligand atom, a fragment or the entire ligand 
molecule in the Hierarchy tree view. Now under Define Site tools collection click on the From 
Current Selection button to create the binding site sphere (see next picture). 
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As demonstrated on the picture above, a new SBD_Site_Sphere item will be defined under the 
5CSW tree in the Hierarchy tree view. Right-click on SBD_Site_Sphere item (blue sphere icon) 
and then click on Attributes of SBD_Site_Sphere. This will open a dialog named SphereObject 
Attributes where some default parameters parameters (XYZ coordinates and radius of the 
sphere) can be customized (see previous picture). 

Now in Hierarchy tree view select again the ligand molecule and remove it from the structure. 
This can be done by a right click on the ligand in the Hierarchy tree view and click Cut on the 
shortcut menu. Open a new Molecule window (File > New > Molecule Window) and paste the 
ligand molecule here. 

Visually inspect the ligand in the Molecule window for possible errors (e.g., atom valences), 
rename the ligand in Molecular detail and navigation panel (e.g., 5CSW_ref) and save the 
ligand molecule as *.mol or *.sdf file (File > Save As…). 

When everything is properly prepared, the system is ready for the next step (Parameterization 
of SBD protocols for molecular docking). 
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Parameterization of SBD protocols for molecular docking calculations 

The parameterizations of the DS SBD protocols (e.g., CDOCKER, GOLD, etc.) for molecular 
docking calculations are mainly automatic. To open a SBD protocol switch to Protocols tab and 
navigate to the SBD protocol of your choice (Protocols tab > Discovery Studio > Receptor-
Ligand Interactions > Docking). Double click on the selected SBD protocol (e.g. CDOCKER). The 
CDOCKER SBD protocol parameter window will open (see picture below).  

 

Parameterize the protocol for your needs and when everything is prepared just click Run (green 
play button) in the Toolbar.  

When the calculation is finished, open the Results in exactly the same way as for the Prepare 
Protein job explained above. 

 

Analysis of docked poses (RMSD of re-docked ligand molecule) 

To analyze the docked poses click on Docked Ligands link in the Result window. This will open 
the docked poses in a new Molecule window. In order to compare how good our results are, we 
need to insert here the co-crystallized ligand we saved previously (File > Insert From > File). 
Rename the inserted original ligand molecules (e.g., 5CSW_ref _orig) and enable visibility of all 
docked poses by putting check marks on visibility option (see picture below). 
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Now select the inserted original co-crystallized ligand (4th row in the previous picture) and label 
it as a reference molecule (main menu > Structure > RMSD > Set Reference) and open the 
Molecule window.  

 

 

In order to calculate the RMSD (it should be <= 2.0 Å), go to main menu (Structure > RMSD > 
Heavy Atoms). This will open the RMSD Report window where all RMSD comparisons are 
displayed. 
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As demonstrated, all docked poses have RMSD below 2.0 Å (that is also visually true), i.e., the 
docking protocol is properly parameterized and ready to be used for performing molecular 
docking calculations on new compounds. 

While still open, switch to 5CSW_prep tab and save as a new *.dsv file (e.g., 
5CSW_prep_final.dsv). 
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A quick introduction to Pipeline Pilot (PP) user interface 

 

 

1. Main PP tool panel 

2. Components collections 

3. PP protocol (assembled of piped components) 

4. Protocol parameters 

5. PilotScript interface 

6. Jobs explorer 
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Preparation of a ligands library for molecular docking calculations 

Regardless of the origin of ligands we would like to dock (e.g., commercially available 
compounds, ligands scrutinized from the literature, or even de novo virtually assembled ligands 
not commercially available), they should be properly pre-treated for molecular docking 
calculations. This means that all of them should be adequately prepared in a machine-readable 
format (e.g., *.mol, *.sd/*.sdf, SMILES, etc.). Comparing to the *.mol file format (commonly 
known as a connection table) that contains structural information (e.g., atoms, bonds and their 
connectivity) related to a single ligand, the *.sdf file format in a broader sense can be regarded 
as a database of significantly higher number of ligands. In fact, *.sdf format contains the same 
information as a single *.mol file, where each ligand (encoded in form of connection tables) are 
separated by "$$$$" delimiter. Moreover, these file formats can store various information 
related to the ligand(s) (e.g., various physico-chemical properties, chemical names, etc.). A 
snippet of these file formats (e.g., molecule of toluene) is given in the picture below.  
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Assuming that our ligands are represented as 2D structures (see previous picture) it should be 
stressed that such a representation is not very recommended for performing molecular docking 
calculations. Put differently, prior to perform molecular docking calculations, all ligands should 
be:  

• Converted to 3D structures,  
• All hydrogen atoms should be added (2D structures are lacking of H-atoms), 

and optionally  

• They should be geometrically minimized (e.g., to remove any van der Walls clashes).  

Finally and also preferably, all ligands should be assembled as one database in an appropriate 
molecular machine-readable formed (e.g., *.sdf). In order to do all these crucial steps in a 
concomitant fashion, we will construct a Pipeline Pilot (PP) protocol (see picture below).  

 

Let's assume that our ligands we scrutinized from different sources (e.g., literature, online 
structural databases, etc.) represent separate 2D molecules, which are either in *.mol or *.sdf 
format. In order to construct a PP protocol (like the one represented above) that will automate 
all the steps described above, we will use PP interface.  

So, here is the step-by-step guide: 

As a very first step, we should read all the ligands we collected (*.mol or *.sdf files). Since, both 
file formats are practically very similar, we will use the so-called SD Reader PP component, 
which is capable to read both formats.  

To do this, in the Components Collection tab, locate SD Reader component (stored in 
Chemistry > Data Access and Manipulation > Readers) and double-click on the SD Reader 
component to put it on the working layout (see picture below). At first, the SD Reader 
component is red, which means that we should add some data to it. Select the red SD Reader 
component on the working layout and in the Parameters window, under Source click the 
corresponding button as depicted in the picture to open the file browser dialog. 
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Navigate to the directory where your ligands are stored, select all ligands, and click on the 
Select button to select them. In this way, the SD Reader component will become blue, while in 
the Parameters window all *.mol and *.sdf files we selected will be separated by commas. The 
parameters for a particular component in the Parameters window will be visible only in case 
the target component is selected in the working layout! 

As we can see on the picture above, the filenames of our ligands are actually their names, so it 
is not a bad idea to use these information in the final *.sdf file (the ligand library we are 
constructing) for easier ligand's recognition. While we have still open the Parameters for the 
selected SD Reader component, locate the SourceTag parameter and from the corresponding 
list select Filename (see picture below).  
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Now, navigate to the Components Collection tab, locate the Custom Manipulator (PilotScript) 
component (stored in Data Access and Manipulation > Manipulators) and double-click it to 
automatically pipe it to the SD Reader component (see picture below). 

 

Once piped, select the Custom Manipulator (PilotScript) component and in the Parameters 
window click the Expression button to open the PilotScript interface. Here, define the Name 
for each ligand as demonstrated on the picture above (Name := SourceTag). In this way we 
constructed a new property named "Name" that contain names of our ligands. Check if the 
PilotScript is correct (5), click on the Apply button (6) and finally click on the OK button (7) to 
close the PilotScript interface. 

Now navigate again to the Components Collection tab and find the following components: 3D 
Coords (located in Chemistry > Data Access and Manipulation > Manipulators > 3D Methods), 
Add Hydrogens (located in Chemistry > Data Access and Manipulation > Manipulators) and 
Minimize Molecule (located in Chemistry > Data Access and Manipulation > Manipulators > 
3D Methods). Double-click each of these components in the same order (3D Coords > Add 
Hydrogens > Minimize Molecule) to pipe them automatically (see next picture). So, the 3D 
Coords component will update the 2D connection table of the input ligands with Z-coordinate, 
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the Add Hydrogens component will also update each input ligand by adding H-atoms, while 
Minimize Molecule will minimize the energy of all input ligands. 

 

 

 

Before to finalize the protocol, we should keep in mind that the final *.sdf library can contain 
some residual properties (e.g., SourceTag, Minimized Energy) that will be generated when the 
protocol will be run.  

Except the "Name" property we created, we actually don't need any other property. In order to 
keep just the "Name" property, we will add one more component (double-click on it) named 
Keep Properties (located in Data Access and Manipulation > Manipulators) to our protocol 
(see next picture). 

After adding the Keep Properties component, select it in the working layout and in the 
Parameters window type the name of the property (e.g., Name) for the needed PropertyList 
parameter (see next picture). In this way our *.sdf library will contain only one property, i.e., 
"Name". 
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Finally, we will finish our protocol by adding the last component named SD Writer (located in 
Chemistry > Data Access and Manipulation > Writers). 
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Select SD Writer component in the working layout and in the Parameters window, under the 
Destination parameter, type the full path and file name with extension (e.g. 
C:\Users\username\Desktop\library_filename.sdf), where username is your username and 
library_filename.sdf is the name of the ligand library in *.sdf format (e.g., in this case b-
raf_inhibitors.sdf). Finally, run the protocol by clicking the green play button from the main PP 
tool panel (3) and wait for it to finish. Moreover, save the protocol for further use (goto File > 
Save Protocol As...) in your home directory. 

 

Molecular docking calculations using DS CDOCKER protocol 

The procedure of performing molecular docking calculations for our previously constructed 
ligand library is actually very similar to the re-docking of the co-crystallized ligand conformation 
within its binding site (see pages 9-10). Previously, we saved our molecular docking settings as a 
*.dsv file named 5CSW_prep_final.dsv, which contains all the important information we 
obtained from the re-docking validation step (e.g., prepared protein, defined appropriate 
calculation sphere as well as the corresponding calculation parameters).  

In order to perform molecular docking calculations for our previously constructed ligand library, 
in Discovery Studio first we will open our well-validated system (goto File > Open... and then 
locate and load the file 5CSW_prep_final.dsv). After this, we will open our prepared ligand 
library as *.sdf format (b-raf_inhibitors.sdf) in a new Molecule window (see picture below). 

 

 

 

Next, switch back on the protein (click on 5CSW_prep_final tab). From Protocols tab navigate 
to the SBD protocol of your choice (Protocols tab > Discovery Studio > Receptor-Ligand 
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Interactions > Docking). Double click on the selected SBD protocol (e.g. CDOCKER). The 
CDOCKER SBD protocol parameter window will open (see next picture).  

 

 

 

Parameterize the protocol as demonstrated on the picture above and click Run (green play 
button) in the Toolbar to start the docking calculation for our ligands.  

When the calculation is finished, in the Jobs tab double-click to open the Results (2) and then 
click on the View Results button (3). This will open a new Molecule window (4) containing our 
protein structure and the docked poses (5) for the ligands (see picture below). 
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Analysis & selection of the most favorable docked poses 

For the selection of the most favorable docked poses, first we will focus on the values for the 
scoring functions (in our case, -CDOCKER_ENERGY and -CDOCKER_INTERACTION_ENERGY) 
calculated by the CDOCKER protocol. These scoring functions demonstrating the binding affinity 
of our ligands in kcal/mol give a first insight about the quality of the results (see picture below). 

 

Here, it is important to take into account the pre-defined "minus" sign of these scoring 
functions (see above picture). Put differently, if -CDOCKER_ENERGY and -
CDOCKER_INTERACTION_ENERGY for a docked pose are both positive values, then we are 
talking about an energetically favorable ligand pose (ligand poses framed in green). Conversely, 
if negative values are obtained, then these docked poses are energetically unfavorable (ligand 
poses framed in red) and consequently we can reject them for further assessments. 

Since, we are interested solely for the energetically favorable docked poses (framed in green), 
we can extract them and further analyze visually within the binding pocket (e.g., ligand spatial 
orientation, interaction of the ligands with the protein's key amino acid residues, etc.). 

 


